スレッド表示 | フラット表示〕 全トピック 920 件中 456 番目 次≫ ≪前

Fedra core3のphpでmbstringが使えないので

created: 2005-03-21 14:48 | modified: 2005-03-25 17:38 | reply: 9

[2183] Fedra core3のphpでmbstringが使えないので

user: TAS | created: 2005-03-21 14:48
お世話になります、本筋からは外れますが

Fedra core3 のデフォルトのPHPではmbstring関数が使えないので(?)、
ソースからmakeを試みましたが
./configure --with-apxs2=/usr/local/apache2/bin/apxs
でエラーとなります、考えられる原因は
1. perl is not instaled
2. apxs is not found
3. Apatch was not build using --enable-so
となります、のでアパッチをソースからインストールしました
./configure --enable-so --enable-module=so --enable-module=rewrite
としました、エラーなく終了したのですが
apxsらしきものは作成されず、結果phpのmakeで同じエラーとなります
httpd-2.0.53+php4.3.10です

何かヒントでもいただけると助かるのですが
reply: 2184 返信 編集 削除

[2184] VineLinux派ですが

user: シロウ | created: 2005-03-22 06:45
はじめましてシロウと申します。
httpd-develパッケージでインストールしてみては如何ですか。

http://www.dolphy.gr.jp/webap/env/php-install.html

VineLinuxではapache2-develの中にあったはずです。
(RedHat系はhttpd2-devel?)

Do You PHP?さんのサイトにはとても参考になるディープな内容を掲載されています。
http://www.pat.hi-ho.ne.jp/dimension/inst/inst_unix_apache2.shtml

http://www.pat.hi-ho.ne.jp/dimension/inst/inst_unix_dso_430.shtml
Parent: 2183  reply: 2185 返信 編集 削除

[2185] Do You PHPをこれから試してみます

user: TAS | created: 2005-03-22 09:46
シロウさん、はじめまして、ありがとうございます
rpm -i httpd-devel-2.0.40-21.3.i386.rpm
は以前、試してありますが、うまくいきませんでした
Do You PHP?さんのサイトはまだ試しておりません、これから試してみたいと思います
Parent: 2184  reply: 2186 返信 編集 削除

[2186] 肝心のlibphp4.so が0バイトになります

user: TAS | created: 2005-03-22 15:55
httpd を
./configure --enable-mods-shared=most
make
make install で
/usr/local/apache2/bin/apxs
はできたんですが、肝心のlibphp4.so が0バイトになります
sapi,cgi とかで、エラーがでてました
暫くゴチョゴチョ頑張ってみます
Parent: 2185  reply: 2187 返信 編集 削除

[2187] もう限界かな・・・

user: TAS | created: 2005-03-22 16:58
php make で
[sapi/cgi/php]エラーとなります
もう限界かな・・・

php-4.3.9 にバージョンを落としましたら
エラーなく
build complete
ですが、libphp4.so は作成されませんでした
Parent: 2186  reply: 2188 返信 編集 削除

[2188] パッケージでPHP5をいれてみては

user: シロウ | created: 2005-03-23 01:42
VineLinux3.1(VinePlus)にあるPHP5のパッケージにはmbstringが入っていました。
(PHP5では多分標準であるはず)

「私の環境では」
php5-5.0.3-0vl1.i386.rpm
php5-apache2-5.0.3-0vl1.i386.rpm
php5-pear-5.0.3-0vl1.i386.rpm
php5-devel-5.0.3-0vl1.i386.rpm … phpの追加モジュールコンパイル時に必要


最近は面倒なのでよほどの事がない限りソースからコンパイルする事をしていません。
お力になれず、申し訳ないです。
Parent: 2187  reply: 2191 返信 編集 削除

[2191] php5を検討してみます

user: TAS | created: 2005-03-24 09:33
シローさん、有難う御座います

操作に間違いないか、別のPCへのインストールを試したり、再度makeしたりしたんですが
同じような結果でした
php5を検討してみます、rpm ですんなり行けば幸いですが
Parent: 2188  reply: 2195 返信 編集 削除

[2195] いろいろ試しましたが、結果×でした

user: TAS | created: 2005-03-25 10:46
いろいろ試しましたが、結果×でした

php5,rpm で試みましたが、依存関係でNG
ソースからbuildしました、何とかcomplete
したんですが、httpd.conf でエラーだらけ
何とか、動くようにしたんですが
libphp5.so のロードはできるんですが
addtype できない
解からんことだらけで、あきらめます
core1 はmbsrtingがOKだったので
戻ろうと考えてます
初めてmakeを経験しました、勉強にはなりました

シローさん、有難うございました
Parent: 2191  reply: 2200 返信 編集 削除

[2200] これはちょっと最後にサイト紹介

user: シロウ | created: 2005-03-25 15:44
rpmの使い方
http://www.a-yu.com/system/rpmc.html

PHPは以下がお互いに依存関係であったはず。(これではないですね)
なので、同時にインストール。
rpm -ivh php5-5.0.3-0vl1.i386.rpm php5-pear-5.0.3-0vl1.i386.rpm

APTによるパッケージ管理(VineLinuxなのでこれ使っています)
http://park15.wakwak.com/~unixlife/linux/rpm-apt.html
依存関係とかも勝手に解決してくれる。


Fedoraだと yumによるパッケージ管理が主流らしい。
FedoraCore4からyumとのGUIが整備・強化されるそうです。
Parent: 2195  reply: 2202 返信 編集 削除

[2202] 残念ですが、もうcore1にしました

user: TAS | created: 2005-03-25 17:38
シローさん、ありがとう
えー、その辺全て何度もチャレンジしましたが
駄目でした。
yum も試しました、rpmのuninstallも何度もやりました。
残念ですが、もうcore1にしました
折角助言いただきながら、申し訳ありません
後日、再挑戦したいと思います
OSの検討も含めて
Parent: 2200  返信 編集 削除
スレッド表示 | フラット表示〕 全トピック 920 件中 456 番目 次≫ ≪前
ページの一番上へ
Googleグックマークに登録 Yahooグックマークに登録 livedoorクリップに登録 @niftyクリップに登録 はてなブックマークに登録 deliciousに登録 Buzzurlに登録 FC2ブックマークに登録
最近更新された掲示板トピックス
管理人Blog
Yahoo Search

最近更新したNote
PHPマニュアル
今日のブックマーク
PHPマニュアル関数検索
関数名を入力し検索ボタンをクリック↑