スレッド表示 | フラット表示〕 全トピック 920 件中 807 番目 次≫ ≪前

MySQLのインストール・リターンズ

created: 2003-09-11 19:27 | modified: 2003-09-13 13:53 | reply: 9

[636] MySQLのインストール・リターンズ

user: ゆうじ | created: 2003-09-11 19:27
@php@さんへ♪
本腰入れて問題を解決する為
スレッドを切り直しました。

WinXP + Apache1.3.28 + PHP4.3.2 +
という環境に、MySQL3.23.57 を
当サイトのMySQLのインストールにしたがって、
インストールしました。

ただしインストール直後に、
winmysqladmn を一度起動させ、my.ini を作成後、
winmysqladmn を終了させ、WinXPを再起動しました。

現在、winmysqladmn は起動しておらず、
コマンドラインからMySQLサービスの登録と解除は出来るものの、
サービスを開始する為、net start mysql を打っても

Mysql サービスを開始します。
Mysql サービスを開始できませんでした。
システム エラーが発生したした。
システム エラー 1067 が発生しました。
プロセスを途中で強制終了します。

と表示され、MySQLサービスが開始できない状態です。


現状はこんな感じでよろしいでしょうか?
さて、ココからが解決編です。


サービスの登録と解除が問題なく出来ているので、
MySQL起動時に問題があることはわかります。

そこで、C:\WINNT 下の my.ini を
以下のように訂正し保存します。

[mysqld]
basedir=C:/server/mysql
datadir=C:/server/mysql/data

[WinMySQLadmin]
Server=C:/server/mysql/bin/mysqld-nt.exe

再び、net start mysql を打ったところ、
「Mysql サービスは正常に開始されました。」と表示され、
無事サービス開始できました。

@php@さんのところだと my.ini はこうなりますね。

[mysqld]
basedir=C:/mysql
datadir=C:/mysql/data

[WinMySQLadmin]
Server=C:/mysql/bin/mysqld-nt.exe

この通りやって解決しなければ、
やっぱり私では無理のようです。

もし違うところがあればお知らせ下さい。
reply: 637 返信 編集 削除

[637] ありがたいです。

user: @php@ | created: 2003-09-12 13:59
やってみました・・・残念ながら同じエラーが戻ってきました(-_-;)これって、お手上げ状態ですかねー?何ででしょうか?ふぅー
Parent: 636  reply: 638 返信 編集 削除

[638] この際

user: unadon | created: 2003-09-12 15:20
一切合切アンインストールして

http://www.a-zia.net/PHP/

これなら何も考えず,そのまま使えますよ.

私はWindows環境でPHPを動かすことが無いのであれこれ言えませんが,
とりあえず入れてみたらPHPが動作しました.
Parent: 637  reply: 639 返信 編集 削除

[639] あのーーー。。

user: @php@ | created: 2003-09-12 15:57
やってみたのですが、?.phpファイルの保存場所って、\Apache Group\htdocsの中でよいですか?それから、IEでhttp://localhost/?.phpですよね。そうすると、ファイルがないと言う表示になるんです。
Parent: 638  reply: 640 返信 編集 削除

[640] DocumentRoot

user: ゆうじ | created: 2003-09-12 16:09
httpd.confのDocumentRootで、
ファイルを置く場所を設定します。
http://www.sound-uz.jp/php/note/config4
Parent: 639  reply: 641 返信 編集 削除

[641] 確認したのですが・・・

user: @php@ | created: 2003-09-12 16:22
DocumentRoot "C:/Program Files/Apache Group/Apache/htdocs"

#
# Each directory to which Apache has access, can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# permissions.
#
<Directory/>
Options FollowSymLinks
AllowOverride None
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "C:/Program Files/Apache Group/Apache/htdocs">

#
# This may also be "None", "All", or any combination of "Indexes",
# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
↑このようになってました。
でもファイルがないっていう表示になってしまうんです。
Parent: 640  reply: 642 返信 編集 削除

[642] 先のフォルダと違いますが?

user: ゆうじ | created: 2003-09-12 16:47
記事[639]の
・・・ \Apache Group\htdocs ・・・
と、httpd.comf の DocumentRoot "C:/Program Files/Apache Group/Apache/htdocs"
とは、異なってるようですが・・・。

もう一度再確認してみてはいかがでしょう。
Parent: 641  reply: 643 返信 編集 削除

[643] 記述ミスです

user: @php@ | created: 2003-09-12 17:19
\Apache Group\htdocsではなくて、\Apache Group\Apache\htdocsの中にファイルを保存してました(^_^.)なので、原因がさっぱりです。
リカバリあてます。
Parent: 642  reply: 644 返信 編集 削除

[644] 複数httpd起動の可能性

user: ゆうじ | created: 2003-09-13 12:57
もう、リカバしてしまいました?

同じような事例が無いかgoogleで検索したところ、
Windowsではありませんが
関係ありそうな記事をみつけました。

この一連のスレッドでは、
複数のhttpdが起動していたために
CGIファイルにアクセスできなかったということです。

解決のヒントになれば幸いです。

▼[Newbie 1189] Re: Not found
http://mm.apache.or.jp/pipermail/newbie/2001-August/001182.html
Parent: 643  reply: 645 返信 編集 削除

[645] 今から再挑戦

user: @php@ | created: 2003-09-13 13:53
昨日リカバリしました?(+_+)
今から再挑戦したいと思います(^.^)
また、わからないことがあると思いますので、
よろしくお願いします!
Parent: 644  返信 編集 削除
スレッド表示 | フラット表示〕 全トピック 920 件中 807 番目 次≫ ≪前
ページの一番上へ
Googleグックマークに登録 Yahooグックマークに登録 livedoorクリップに登録 @niftyクリップに登録 はてなブックマークに登録 deliciousに登録 Buzzurlに登録 FC2ブックマークに登録
最近更新された掲示板トピックス
管理人Blog
Yahoo Search

最近更新したNote
PHPマニュアル
今日のブックマーク
PHPマニュアル関数検索
関数名を入力し検索ボタンをクリック↑