スレッド表示 | フラット表示〕 全トピック 924 件中 794 番目 次≫ ≪前

PHPはどのバージョンを使うのがよいのでしょうか

created: 2003-09-30 14:37 | modified: 2003-10-01 10:32 | reply: 3

[721] 最新バージョンを推奨

user: hamaji | created: 2003-09-30 20:31
> 現在RedhatLinux+Apache+PHP4.0.6+MySQLを利用しているのですが
この環境は実際のサーバーでしょうか?それともレンタルサーバーでしょうか?
それともローカルマシンのことでしょうか?
文面からはそれが読み取れませんが、いずれにせよ、http://www.sound-uz.jp/php/bbs/index.php?mode=new&num=691
のスレッドにあるように私も最新バージョンを推奨します。

> 調べてみると現在はPHP4.3.3がリリースされています。
> PHPには安定しているバージョンとかあるのでしょうか。最新にした方がよいのでしょうか。
OSや一般のアプリケーションソフトにバグがあるようにプログラム言語にもバグはつき物です。

まして、PHPはまだ、発展途上の言語です。
あのJava言語もバグ修正や仕様追加などを繰り返し、発展してきました。
なので完全なものなどないといえるでしょう。
(あくまでも個人的な見解です。)

私はPHP4以降しか使ったことがないですが、安定しているバージョンをしいてあげるならPHP4.3以降でしょうか。
http://nxweb.dyndns.org:8080/php/news_4_3_3.html
にもあるようにPHP4.3でも大幅なバグ修正が行われています。
また来年早々にもPHP5.0がリリースされるのでは?という情報もありますので、常に最新の情報を取り入れ、随時新しいものにしていくことをオススメします。
Parent: 720  返信 編集 削除
スレッド表示 | フラット表示〕 全トピック 924 件中 794 番目 次≫ ≪前
ページの一番上へ
Googleグックマークに登録 Yahooグックマークに登録 livedoorクリップに登録 @niftyクリップに登録 はてなブックマークに登録 deliciousに登録 Buzzurlに登録 FC2ブックマークに登録
最近更新された掲示板トピックス
管理人Blog
Yahoo Search

最近更新したNote
PHPマニュアル
今日のブックマーク
PHPマニュアル関数検索
関数名を入力し検索ボタンをクリック↑